Task: Create VLANs as given in the topology

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan
Switch(config)#vlan 10
Switch(config-vlan)#name USERS
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name SERVERS
Switch(config-vlan)#exit
Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Task: Assign fa0/1 & fa0/2 to VLAN 10 and fa0/3 & fa0/4 in VLAN 20 

Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface range fa0/1-2
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#exit
Switch(config)#interface range fa0/3-4
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#exit
Switch(config)#end
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Task: Create Switch Virtual Interfaces (SVI) on the Multi-Layer switch which will act as a gateway for the users in VLAN 10 & VLAN 20

Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface vlan 10
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

Switch(config-if)#description *GATEWAY FOR VLAN10*
Switch(config-if)#encapsulation dot1q 10
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

Switch(config-if)#description *GATEWAY FOR VLAN20*
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Task: Enable IP Routing on the Multi- Layer Switch and check the Routing Table  

Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#ip routing
Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Verification: Users in VLAN 10 should be able to ping users in VLAN 20 and vice- versa

2 comments

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.